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SDK and initial setup: Outline

� Today:
▪ How to setup a machine to start developing Android 

applications
▪ An overview of an Android project
▪ Some useful tools
▪ Your first Android application

•Maybe on a real device!
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(Not really) two options

� Historically Android development was in Eclipse
�  Download the SDK
� Install the Android plugin

� Now there is Android Studio: the official 
development platform
�Customized environment

https://developer.android.com/studio
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Which one?

● For LAM, it’s the same: if you already use and 
love Eclipse, go with it
○ You might see examples done in both platforms

■ You can always import an Eclipse project into Android Studio
■ The inverse is difficult

BUT
● Eclipse SDK has been DEPRECATED since the 

end of 2015, which means newer versions of 
Android are no longer supported.
○ Want a better explanation?

https://android-developers.googleblog.com/2015/06/an-update-on-eclipse-android-developer.html

https://android-developers.googleblog.com/2015/06/an-update-on-eclipse-android-developer.html
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Android Studio
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Where and how to get it

● Go to https://developer.android.com/studio
● Download Android Studio and the SDK
● Install it and you’re done!

Version 
Bumblebee
2021.1.1 patch 1
at the time of writing

https://developer.android.com/studio
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What’s new compared to past two 
years...

Changes from 3.5.3 to 4.1.2

● Database Inspector for querying application databases
● Studio templates now use Material Design Components and Themes
● Ability to run Android Emulator inside of Android Studio
● Support for Dagger Navigation library
● Support for TensorFlow Lite models
● All improvements from IntelliJ IDEA 2020.1.4
● Support for foldables in the Android emulator
● Faster Builds using Apply Changes for devices running Android 11 or higher
● Ability to export C/C++ dependencies from AARs
● Improvements to System Trace UI and Native Memory Profiling
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What’s new compared to past two 
years...

Changes from 4.1.2 to Bumblebee

● New Device Manager
○ The old AVD manager has been removed, now there is a new tab that lets you quickly 

get access to all the virtual and physical devices.
● ADB (android debug bridge) now works over WiFi on android phones that run Android 11 or 

later.
● Android Gradle Plugin for running instrumented tests
● Other stuff… 



 Federico Montori - Programming with Android – SDK install and initial setup 9

Basic requirements

● How to develop Android applications?
○ Linux / Mac OS / Windows? Doesn’t matter
○ A real device is not mandatory

■ although suggested...

● Code your application in the IDE
○ Test it with the emulator
○ Deploy it on a real device (if you can)
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A bit of terminology

● SDK (Software development kit)
○ A set of tools that help you in creating software
○ Compiler, tester, debugger, libraries

● IDE (Integrated Development Environment)
○ Graphical environment in which all the tools are 

accessible.
● API (Application Program Interface)

○ A set of calls that the underlying world exposes to 
the developer for interaction.

○ It does not correspond to “libraries”.
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SDK manager

Tools > SDK Manager

� Android tool

� Used to get APIs 
and add-ons

� You can also start it
from Android Studio

� It’ll affect the
compileSdkVersion
(details later)
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Your first Android application

� Go to File > 
New Project

Newest version of
Android Studio
makes you choose
first which kind of
activity you want 
to
start with.
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Your first Android application

� Go to File > New Project

Your activity will be
named MainActivity by
default (Java class).

Of course you can
refactor it ... 
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Your first Android application

� Go to File > New Project

Choose carefully
which API version
to use.

Low version = 
high compatibility

Low version = 
less features
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Your first Android application

� This was from last 
year, just as a 
comparison!
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Your first Android application
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Your first Android application
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Creating an emulator

Hit Tools > 
Device Manager
Previously AVD
AVD = Android Virtual Device

You can select 
options for the 
emulator

You can create as 
many as you want
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Creating an emulator

Hit Tools > 
AVD Manager
AVD = Android Virtual Device

You obviously 
need to download 
the Android system 
image for the 
version you want.
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Creating an emulator

Hit Tools > 
AVD Manager
AVD = Android Virtual Device

Wanna test it?

Hit the Play button
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Creating an emulator

Hit Tools > 
AVD Manager
AVD = Android Virtual Device

If you run it, it will turn on and resemble 
pretty much a real device.
It is legit a virtual machine.

YES you can use the internet (by default 
each AVD is individually NATted).
NO you can’t call (lol)
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All good? Test it!

Hit Run > Run ‘app’

� Test in on the emulator

� You should see something 
similar to this
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Delving into versions and building

Hit “File > Project Structure > Modules” and you’ll see two 
sections  that’ll help you deal with versioning.

● Properties
○ versioning and other stuff at Compile time
○ Mostly having to do with Gradle

● Default Config
○ versioning and other stuff at Run Time
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Android: versions

4

2008
API 1

2009
API 3

2009
API 4

2009
API 5

2010
API 8

2010
API 9

2011
API 11

2011
API 14

2012
API 16

2013
API 19

2014
API 21

2015
API 23

2015
API 24

2017
API 26

2018
API 28

2019 - API 29 
Initially “Android Q”

No more desserts...

2020 - API 30 

  Android
 “R”

4

2021 - API 31 
2022 - API 32 

Tiramisu in in preview!
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Delving into versions and building

What is Gradle?

It’s the official build automation tool for Android, coming 
with a lot of optimizations.

It has config files that can be modified through the 
Android Studio GUI.

It manages build configurations that no longer are 
assigned to the Android Developer.

- New Gradle two weeks ago… https://gradle.org/whats-new/gradle-7/ 

https://gradle.org/whats-new/gradle-7/
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Delving into versions and building

compileSdkVersion

● Used by Gradle to compile the project
● i.e. which set of classes and functions should I use?
● It’s the newest possible SDK theoretically supported by your 

app (watch out, NOT the API).
● Suggested to use the latest available (unless you haven’t 

learned it yet… )
● It’s COMPILED, therefore retro-compatibility is structurally 

ensured.
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Delving into versions and building

minSdkVersion

● Indicates which is the oldest release of the SDK (but also 
API) your app is compatible with...

● … though it is compiled with another version.
● Obviously you cannot implement certain functionalities (e.g. 

channels).
● In practice if a customer has a phone that’s too old, then the 

app is neither installable nor visible.
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Delving into versions and building

targetSdkVersion

● Indicates which is the newest release of the SDK (but also 
API) your app is compatible with...

● … in practice it tells what is the expected version.
● It is ideally the same as the compileSdkVersion, however it 

can be older if newer versions had not been tested.
● In short:

○ minSdkVersion <= targetSdkVersion <= compileSdkVersion
● Even though it’s better:

○ minSdkVersion <= targetSdkVersion == compileSdkVersion
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Hello world, Android!

� Anatomy of an application
�Activity: what is started
�View: what is seen
� Intent: how to communicate with others

� Mix of XML and Java
�Generally XML for layouts
� Java for the app logic
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Activities, Intents and Views

Activity

View Intent View

Activity
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The java and res folders

The code of your application:
● The java folder contains… the 

java code!
● Inside res there are a lot of 

resources
○ Images
○ Layouts
○ Xml files
○ Strings

● AndroidManifest.xml
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AndroidManifest.xml

Mandatory file for every 
application
● Contains:

○ Application declaration
○ Permissions
○ Intent filters
○ Targets
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How to test

� Via an AVD
� Fast, possible to have different resolutions, APIs
� Not a real device

� On a real device
� You get exactly what is deployed
� Must own a real device

� So?
� Test in on AVDs.
� When you feel that the application is ready, go with a real device



 Federico Montori - Programming with Android – SDK install and initial setup

Test on a Real Device

Mainly 2 ways of doing it:

● Via USB debugging (more for debugging)
○ Phone must have developer options and USB debugging enabled 

(howto: 
https://developer.android.com/studio/debug/dev-options.html#enable)

○ PC’s OS must have the correct driver/module (howto: 
https://developer.android.com/studio/run/device#setting-up)

○ Can then run apps just by hitting the Run > Run ‘app’
○ You can use the newest WiFi pairing!

● Create an apk (more for releasing and sharing)
○ Must be signed

https://developer.android.com/studio/debug/dev-options.html#enable
https://developer.android.com/studio/run/device#setting-up
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Test on a Real Device

Here’s the app running on 
my Samsung A40 with 
Android 10.

-------------------------------->
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How to deploy through APK

� Android applications must be signed before installing 
them on a real device.

Hit: Build >
Generate Signed Bundle / APK

  

You need a key for this 
and you can generate 
one from the menu.

You can potentially use 
no key, but it will 
generate a debug 
version.

You can generate a Bundle (ABB) alternatively:
a Bundle is Google Play’s new app serving model, called 
Dynamic Delivery, then uses your app bundle to generate and 
serve optimized APKs for each user’s device configuration, so 
they download only the code and resources they need to run 
your app. You no longer have to build, sign, and manage 
multiple APKs to support different devices, and users get 
smaller, more optimized downloads. It is a publishing format.
https://developer.android.com/guide/app-bundle   

https://developer.android.com/guide/app-bundle
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How to deploy through APK

� Using here V2 Signature (faster, since Android 7.0)
https://developer.android.com/about/versions/nougat/android-7.0.html#apk_signature_v2

… transfer the .apk file to your phone and you’re done.

https://developer.android.com/about/versions/nougat/android-7.0.html#apk_signature_v2
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How to deploy

� To be published on the market, you have to pay 25 
Euro
� Lifetime fee, unlimited APPs
�Not required for the LAM class

� Upload the APK or the ABB, and in few hours/days 
the APP is on the play store
�Receive comments, improve, update
�Smartphone specific bugs? AVDs
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Android Developer Console

https://www.google.it/url?sa=i&rct=j&q=&esrc=s&source=images&cd=&ved=2ahUKEwiQ0afg6srZAhWIJlAKHXIjArcQjRx6BAgAEAY&url=https://android-developers.googleblog.com/2012/10/new-google-play-developer-console.html&psig=AOvVaw0JNJOFA-eSEV8Ju1kUFW9B&ust=1519983719888633

