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Mobile Apps

“A mobile application, also referred to as a mobile app or simply an app, is a 
computer program or software application designed to run on a mobile device 

such as a phone, tablet, or watch”
Wikipedia
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Mobile Apps: Native

● A native mobile app is intimately tied to the platform on which it is running. 
● It has the ability to fully integrate with the capabilities of both the hardware 

and the OS on which it resides. 
● It is completely analogous to most PC applications, which are downloaded to 

a desktop or laptop hard drive and completely executed within that machine.
● In order to accomplish this tight integration, the mobile app developer utilizes 

an SDK from the hardware manufacturer directly or via the mobile device’s OS 
vendor.

● Combined with an IDE, a developer is able to code the mobile application 
logic and take advantage of any hardware or OS functionality that is available 
via the exposed APIs
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Mobile Apps: Hybrid

● A hybrid mobile application is developed using both native libraries and web 
technologies in an attempt to get the best of both worlds. 

● The interface between the separate components is an on-platform, 
embedded HTML rendering engine, which is either developed in-house or by 
acquiring one from a 3rd-party.

● The native portion of the app can be written as a top to bottom native app, 
which communicates to a web-based server backend. This has the same 
porting issues as a purely native app. 

● 3rd-party cross-platform development tools exist that use native library 
containers to achieve near-native performance. Such tools bring the benefits 
of cross-platform development in both the native and web-based portions of 
a hybrid mobile app
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Mobile Apps: Web apps

● Web-based mobile apps and Progressive Web Apps (PWA) are developed 
with the same tools used for mobile website development through the use of 
HTML, CSS style sheets and JavaScript.

● HTML5 provides the ability to create rich UI experiences with support for rich 
media, UI components, geolocation, and offline execution.

● Third-party suppliers of JavaScript toolkits can supply UI components that 
allow web-based apps to mimic native look and feel on the mobile device, 
such as Dojo or jQuery. However, their ability to provide precise native look 
and feel varies across toolkits.
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Mobile Apps: Comparison

Hybrid

● Web technologies (HTML, CSS, 
Javascript)

● Run in a browser Web View
● Access device capabilities via 

plugins
● Wrapped in a native app shell
● Native app

PWA

It is just a regular website that runs in a 
browser with some enhancements and 
gives app-like experience to users by 
using modern web capabilities.
● Installation on a mobile home 

screen
● Offline usage
● Camera, push notifications
● Background synchronization
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Mobile Apps: Comparison

Native Hybrid Mobile Web
(PWA)
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Mobile Apps: Comparison

Hybrid-Native Hybrid-Web
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Mobile Apps: Comparison

Owned by Ionic
● Basically Web code running 

into a WebView
● Capacitor is an evolution of 

Cordova/PhoneGap
● Works very well for the Web 

too
● Good if you want to reuse 

code from your Web 
Application (Angular, React, 
Vue, …)

Owned by Google
● Code in Dart, render in 

native
● Declarative UI (similar to 

Swift/Components)
● A lot of widgets OOTB
● Not very good for the web, it 

renders everything into a 
canvas.

● Good if you want to start 
from scratch.

Owned by Facebook
● You need to code in React
● Renders elements in native 

elements
● EXPO
● Few basic components,  

(too) many plugins
● Good if you want to reuse 

(some) React code but be 
closer to the native render
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Mobile Apps: Comparison

Hybrid-Native: Native UI, Shared Code
JavaScript code runs and orchestrates native UI controls under the hood, so 
that your app UI is running (almost but not completely) natively. It means that 
the underlying native UI component that you would like to use or customize 
must be supported by the framework in order to use that component or 
change it.
Hybrid-Web: Web UI, Shared Components
The UI is built with HTML/CSS/JS, with native functionality being accessed 
through portable APIs (or “plugins”) that abstract the underlying platform 
dependencies.Instead of your entire UI depending on the native platform, only 
certain native device features, like the Camera, are platform-dependent.
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Mobile Apps: Comparison

Native, Hybrid or PWA ?
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Mobile Apps: Comparison

Native, Hybrid or PWA ?

Of course, it depends…



14

Mobile Apps: Comparison

Native
● Direct access to all 

the mobile device’s 
features

● Highest 
performance 
possible

● Direct access to UI 
components of 
specific platforms

Web
● No fee nor approval 

procedures to 
publish the 
application

● No installation 
required

● Lowest 
development costs

● Single codebase

Hybrid
● Easy access to 

mobile device’s 
features

● UX is nearly 
identical to native 
apps

● High performances
● Single codebase, 

and lower 
development costs
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Mobile Apps: Comparison

Native
● Highest 

Development & 
Maintenance costs

● Multiple codebases
● High Development 

Time
● Limited 

customization

Web
● Limited set of 

functionalities
● Worse UX
● The efficiency and 

the quality of the 
application strongly 
depends on the 
technology used

● Worst performances

Hybrid
● High Development & 

Maintenance costs
● The efficiency and 

the quality of the 
application strongly 
depends on the 
technology used

● Worse 
performances
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Android Studio

The official development platform for Android Apps is Android Studio by 
JetBrains.

Historically Android development was in Eclipse with and android plugin.
● Eclipse SDK has been DEPRECATED since the end of 2015, which 

means newer versions of Android are no longer supported.
○ https://android-developers.googleblog.com/2015/06/an-update-on

-eclipse-android-developer.html 

https://android-developers.googleblog.com/2015/06/an-update-on-eclipse-android-developer.html
https://android-developers.googleblog.com/2015/06/an-update-on-eclipse-android-developer.html
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Android Studio
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Android Studio

● Go to https://developer.android.com/studio
● Download Android Studio and the SDK
● Install it and you’re done!

○ Version Hedgehog at the time of writing

https://developer.android.com/studio
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Android Studio

How to develop Android applications?
● Linux / Mac OS / Windows? Doesn’t matter
● A real device is not mandatory although suggested...

● Code your application in the IDE
○ Test it with the emulator
○ Deploy it on a real device (if you can)
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Small Glossary…

SDK (Software development kit)
● A set of tools that help you in creating software

○ Compiler, tester, debugger, libraries
IDE (Integrated Development Environment)
● Graphical environment in which all the tools are accessible.
API (Application Program Interface)
● A set of calls that the underlying world exposes to the developer for 

interaction.
○ It does not correspond to “libraries”.
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SDK Setup

Tools > SDK Manager

Android tool Used to get APIs  and 
add-ons

You can also start it from Android 
Studio

It’ll affect the compileSdkVersion 
(details later)
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SDK Setup

Tools > SDK Manager
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SDK Setup

Tools > SDK Manager

Android tool Used to get APIs  and 
add-ons

You can also start it from Android 
Studio

It’ll affect the compileSdkVersion 
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Hello World App

Go to File > New Project

Newest version of
Android Studio
makes you choose
first which kind of
activity you want to
start with.
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Hello World App

Go to File > New Project

Your activity will be
named MainActivity by
default (Java class).

Of course you can
refactor it ... 
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Hello World App

Go to File > New Project

Choose carefully
which API version
to use.

Low version = 
high compatibility

Low version = 
less features
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Hello World App

“Whatever you do in IntelliJ IDEA, you do that in the 
context of a project. A project is an organizational 
unit that represents a complete software solution.
Your finished product may be decomposed into a 
series of discrete, isolated modules, but it's a 
project definition that brings them together and 
ties them into a greater whole.”

This means that in theory you can develop more 
that one app within the same project but you will 
hardly want to do so.
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Hello World App

The code of your application:
● The java folder contains… the java code!

○ … or Kotlin actually
● Inside res there are a lot of resources

○ Images
○ Layouts
○ Xml files
○ Strings

● AndroidManifest.xml
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Hello World App

Android Manifest
the only file exposed to the OS

Mandatory file for every application
Contains:
● Application declaration
● Permissions
● Intent filters
● Targets
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Hello World App
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Hello World App
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Running the App

Hit Tools > 
Device Manager
Previously AVD
AVD = Android Virtual Device

You can select options for 
the emulator

You can create as many as 
you want
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Running the App

Hit Tools > 
Device Manager
Previously AVD
AVD = Android Virtual Device

You obviously need to 
download the Android system 
image for the version you want.
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Running the App

Hit the play button 
for testing!
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Running the App

If you run it, it will turn on and resemble pretty 
much a real device.
It is legit a virtual machine.

YES you can use the internet (by default each AVD 
is individually NATted).
NO you can’t call (lol)
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Running the App

Hit Run > Run ‘app’

Test in on the emulator

You should see something 
similar to this



37

Running the App

You can also test the app on a real device: there are two ways to do it:
● Via USB debugging (more for debugging)

○ Phone must have developer options and USB debugging enabled 
( https://developer.android.com/studio/debug/dev-options.html#enable)

○ PC’s OS must have the correct driver/module 
( https://developer.android.com/studio/run/device#setting-up)

○ You can then run apps just by hitting the Run > Run ‘app’
○ You can use the newest WiFi pairing!

● Create an apk (more for releasing and sharing)
○ Must be signed

https://developer.android.com/studio/debug/dev-options.html#enable
https://developer.android.com/studio/run/device#setting-up
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Running the App

Here’s the app running 
on my phone
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Versioning

Hit “File > Project Structure > Modules” and you’ll see two sections  
that’ll help you deal with versioning.

Properties
versioning and other stuff at Compile time
● Mostly having to do with Gradle

Default Config
versioning and other stuff at Run Time
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Versioning

What is Gradle?

It’s the official build automation tool for Android, coming with a lot of 
optimizations.
It has config files that can be modified through the Android Studio 
GUI.
It manages build configurations that no longer are assigned to the 
Android Developer.
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Versioning

Gradle features
● Build types

○ Release, debug, etc…
● Product Flavors

○ Free and paid versions… 
● Manifest Entries

○ Override values on the manifest files
● Dependencies

○ Reference to libraries to import (Maven style) that are not included by 
default in the Android build.

● Signing
○ Configuration for signing your app during the build process…

● …
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Versioning

compileSdkVersion

● Used by Gradle to compile the project
● i.e. which set of classes and functions should I use?
● It’s the newest possible SDK theoretically supported by your app 

(watch out, NOT the API).
● Suggested to use the latest available (unless you haven’t learned 

it yet… )
● It’s COMPILED, therefore retro-compatibility is structurally 

ensured.



43

Versioning

minSdkVersion

● Indicates which is the oldest release of the SDK (but also API) 
your app is compatible with...

● … though it is compiled with another version.
● Obviously you cannot implement certain functionalities (e.g. 

channels).
● In practice if a customer has a phone that’s too old, then the app 

is neither installable nor visible.
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Versioning

targetSdkVersion

● Indicates which is the newest release of the SDK (but also API) your 
app is compatible with...

● … in practice it tells what is the expected version.
● It is ideally the same as the compileSdkVersion, however it can be 

older if newer versions had not been tested.
In short: 

minSdkVersion <= targetSdkVersion <= compileSdkVersion
Even though it’s better:

minSdkVersion <= targetSdkVersion == compileSdkVersion
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Deploying

Android applications must be signed before 
installing them on a real device.
Hit: Build >
Generate Signed Bundle / APK

  

You need a key for this 
and you can generate 
one from the menu.

You can potentially use 
no key, but it will 
generate a debug 
version.

You can generate a Bundle (ABB) alternatively:
a Bundle is Google Play’s new app serving model, called Dynamic 
Delivery, then uses your app bundle to generate and serve 
optimized APKs for each user’s device configuration, so they 
download only the code and resources they need to run your app. 
You no longer have to build, sign, and manage multiple APKs to 
support different devices, and users get smaller, more optimized 
downloads. It is a publishing format.
https://developer.android.com/guide/app-bundle  

https://developer.android.com/guide/app-bundle
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Deploying

Using here V2 Signature (faster, since Android 7.0)
https://developer.android.com/about/versions/nougat/android-7.0.html#apk_signature_v2

… transfer the .apk file to your phone and you’re done.

https://developer.android.com/about/versions/nougat/android-7.0.html#apk_signature_v2
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Deploying

To be published on the market, you have to pay 25 $

● Lifetime fee, unlimited APPs

● Not required for the LAM class

● Upload the ABB, and in few hours/days the APP is on the play store

○ Since a few years the APK is not accepted anymore.

● Receive comments, improve, update

● Smartphone specific bugs? AVDs
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Deploying
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https://play.google.com/console
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Deploying

● Privacy Policy

● A lot of claims about what you are going to do with user data…

● Internal Tests

○ a.k.a. distribute the apk with a handful of friends

● Closed Tests (Mandatory)

○ create a distribution list via the dashboard of at least 20 ppl

● Open Tests

○ every time you update you can pre-release the test version
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